DB/NoSQL/Etc2014.04.11 18:02



공식 홈페이지 : http://webscalesql.org/

GithubUrl : https://github.com/webscalesql/webscalesql-5.6


뉴스기사 : 페이스북·구글·트위터·링크드인, 오픈소스 MySQL 프로젝트 참여

LinkUrl : http://www.ciokorea.com/news/20410

그린은 웹스케일SQL에 기여하는 사람들이 이미 다음과 같은 몇 가지 결과를 만들어 냈다고 밝혔다.
•각각 제안된 변경을 위해 MySQL에 장착된 테스트 시스템(mtr)을 배포하고 실행할 자동화 프레임워크
•스트레스 테스트와 성능 테스트 시스템을 자동화한 프로토타입의 새로운 전체 제품군
•불필요한 충돌이나 테스트 실패를 야기하는 문제를 방지하기 위한 기존 테스트와 일부 기존 코드 구조 변경 또는 안전한 코드 변경
•버퍼 풀 넘침 현상 개선, 특정 유형의 쿼리에 대한 최적화, NUMA 인터리브 정책에 대한 지원 등을 포함한 성능 향상


=> 버퍼 풀 넘침 현상개선이라 흠흠.... 

=> mysql VS mariaDB VS  webscalesql 되는 구조가 될지...아니면 webscalesql은 그냥 mysql에 종속되는 구조인지....... 음흠.......

Posted by 시니^^
Programming/JAVA2014.04.11 16:59

1. Help => Install new software 

   또는 아래 Help => Eclipse Marketplace 에서 svn 검색 후 설치




2. 설치하고 나니까... 아래 SVN Connector.에러 나옴

---------------------------------------------------------------------------------------------------

Share project was failed.

Selected SVN connector library is not available or cannot be loaded.

If you selected native JavaHL connector, please check if binaries are available or install and select pure Java Subversion connector from the plug-in connectors update site.

If connectors already installed then you can change the selected one at: Window->Preferences->Team->SVN->SVN Connector.

----------------------------------------------------------------------------------------------------

※ Connection에 필요한 SVN Kit, JavaHL라이브러리 경우 EPL(Eclipse Public License) 적용될 때 법적 문제의 소지로 인해 별도로 설치할 수 있도록 배포되고 있다고함.



4. SVN Kit, JavaHL라이브러리 추가 Install 로 진행(Help => Install new software)

 => 추가 저장소 등록(Add Repository)

     http://community.polarion.com/projects/subversive/download/eclipse/3.0/update-site/



Posted by 시니^^
TAG Eclipse, STS, svn
Programming/JAVA2014.04.09 22:16

1. Microsoft에서Microsoft SQL Server JDBC 다운로드

1) SQL Server JDBC 드라이버 4.0 (SQL Server 2000 버전 지원 안한다고함) 

URL : http://www.microsoft.com/ko-kr/download/details.aspx?id=11774


2) SQL Server JDBC 드라이버 3.0

URL : http://www.microsoft.com/ko-kr/download/details.aspx?id=21599



2. sqljdbc.jar와 sqljdbc4.jar 차이점

http://msdn.microsoft.com/ko-kr/library/ms378422.aspx

 sqljdbc.jar

 라이브러리는 JDBC 3.0을 지원합니다. 

 라이브러리에는 JRE(Java Runtime Environment) 버전 5.0이 필요합니다.

 JRE 6.0에서 sqljdbc.jar을 사용하면 데이터베이스에 연결할 때 예외가 발생합니다.

 JDBC 드라이버는 JRE 1.4를 지원하지 않습니다.

 JDBC 드라이버를 사용하려면 JRE 1.4를 JRE 5.0 또는 JRE 6.0으로 업그레이드해야 합니다. 

 응용 프로그램이 JDK 5.0 이상과 호환되지 않아 다시 컴파일해야 하는 경우도 있습니다. 

 자세한 내용은 Sun Microsystems 웹 사이트의 설명서를 참조하십시오.

 sqljdbc4.jar

 라이브러리는 JDBC 4.0을 지원합니다. 

 이 라이브러리에는 sqljdbc.jar의 모든 기능과 함께 새로운 JDBC 4.0 메서드가 포함되어 있습니다.

 클래스 라이브러리를 사용하려면 JRE(Java Runtime Environment) 버전 6.0이 필요합니다.

 JRE 1.4 또는 5.0에서 sqljdbc4.jar을 사용하면 예외가 발생합니다.

 응용 프로그램을 JRE 6.0에서 실행해야 하는 경우에는 JDBC 4.0 기능을 사용하지 않더라도  sqljdbc4.jar을 사용하십시오.

JDBC 드라이버는 모든 주요 Sun 호환 Java 가상 컴퓨터에서 작동하고 지원되도록 설계되어 있지만 테스트는 Sun JRE 5.0 이상에서 수행됩니다


3. cmd에서 mvn install

C:\>mvn install:install-file -Dfile=sqljdbc.jar -DgroupId=com.microsoft.sqlserver -DartifactId=sqljdbc4 -Dversion=4.0 -Dpackaging=jar

C:\>mvn install:install-file -Dfile=sqljdbc4.jar -DgroupId=com.microsoft.sqlserver -DartifactId=sqljdbc4 -Dversion=4.0 -Dpackaging=jar


4. pom.xml에 등록

        <!-- MSSQL -->

        <dependency>

            <groupId>com.microsoft.sqlserver</groupId>

            <artifactId>sqljdbc4</artifactId>

            <version>4.0</version>

        </dependency>

Posted by 시니^^

티스토리 툴바